The title say it all. I am trying to find good naming convention for my functions. Some suggestions are here but I would like to know your opinion and if it is possible to use shorter name and still preserve the meaning of the function. This is my function:
sub convert_AoA_to_HoA_where_hash_key_is_element_from_particular_inner_array_index_and_hash_value_is_reference_to_this_inner_array(){
my ($argv1, $argv2, $argv3) = @_;
my @AoA = @$argv1;
my $HoA = $argv2;
my $index = $argv3;
foreach my $array (@AoA){
$HoA->{"$array->[$index]"} = $array;
}
}