I'd like some help with the naming conventions that I have used for my application. Here's what I have:
public class BaseController : Controller
{
public BaseController()
{
}
[Dependency]
public IContentService _cs { get; set; }
}
public class ContentsController : BaseController
{
public ContentsController(
IContentService contentService)
{
_cs = contentService;
}
Can someone let me know if I should perhaps choose a better naming convention and also if the way I set public is correct?
Update:
I only use _cs inside the Contents controller. Should I have a different access property for this? Should it be private or protected in the base controller?