Which of the following declarations conforms to Java's naming conventions?
private boolean writerIsEnabled;
// with methods like
public boolean getWriterIsEnabled()
public void setWriterIsEnabled()
OR
private boolean writerEnabled;
// with methods like
public boolean getWriterEnabled()
public void setWriterEnabled()
I personally find the first name "writerIsEnabled" to be more readable, especially when you use it in an if statement like this -
if(writerIsEnabled)
{
//...
}