When writing Boolean getter/setter methods it seems standard to write them like so
void setValue(boolean value) { }
boolean getValue() { return true/false; }
However I have seen some usage which states that the getter method should be named appropriately according to its usage.
Lets say for example I am setting/getting a Boolean called "enabled", should my getter be called:
getEnabled()
or
isEnabled()
again lets say for example I am setting/getting a Boolean called "nodes", should my getter be called:
getNodes()
or
hasNodes()
Is this just down to personal preference, or is it good practice to choose a particular naming convention over another?