I have this abstract class named as RenderableEntity .
I have a public method render()
that has some logic wrapped around abstract protected render()
method. How should I name this abstract render()
method. Is there some kind of convention eg. doRender()
, makeRender()
for protected method render()
?
public abstract class RenderableEntity extends Entity {
private boolean visible;
public void render(){
if(visible){
render();
}
}
protected abstract void render();
}
Edit: I know this snippet does not compile. I was just wondering how to name this abstract method since I can't have methods with same name and same parameters.