If computeGlobalTransforms
is an instance method of the class m_root
object, and if m_root
is a class property of self
, then the syntax is:
[self.m_root computeGlobalTransforms].
I'd suggest you refer to Methods and Messaging in Learning Objective-C: A Primer.
If computeGlobalTransforms
is a VA_Bone
method, the syntax would be:
VA_Bone *bone = [[VA_Bone alloc] init];
[bone computeGlobalTransforms];
Your bone
variable is a simple local variable, thus no reference to self.m_root
is needed.
By the way, as a matter of convention, the underscores in the middle of variable and class names is generally not used. See Naming Properties and Data Types in the Coding Guidelines for Cocoa. Also see references to "camel case" in the Conventions of Programming with Objective-C.
Thus, a more common naming convention would be VABone
for your class. Likewise for your original m_root
property that you alluded to, you'd (a) give it a more descriptive name; and (b) use camel case. Now I don't know what the "m" of m_root
is supposed to stand for (which, alone, illustrates the problem), but let's say it it was for medium sized images, then it might be mediumSizedImagesRoot
, or whatever.