This is sort of a duplicate question, but there was no real resolution.
So here we go. Lets say I have:
public enum Color
{
Red,
Blue,
Green
}
public class BlueUnicorn
{
private const Color Color = Color.Blue;
}
"Use a singular name for most Enum types, but use a plural name for Enum types that are bit fields." retreived from Microsoft's Enumeration Type Naming Guidelines Check!
"Consider giving a property the same name as its type." retreived from Microsoft's Names of Type Members Check!
I should be using a constant instead of readonly, according to Resharper
Check!
But I get a compiler error. It's odd though, no intellisense on this. The evaluation of the constant value for 'BlueUnicorn.Color' involves a circular definition.
I feel like I'm in a convention crack here. What should the field be named according to best practices naming convention?