I was wondering whether it would be ok to name the variable name for a promise just like the argument passed to a callback:
var dbItems = db.find();
dbItems.then(function(dbItems) {
// Do some stuff with dbItems here...
});
I think that would be syntactically correct, but are there any arguments (like possible confusion or readability) against using this from the perspective of code style?