It's right to do something like this but it's not recommended as by c# properties convention
From MSDN :
Unlike other members, properties should be given noun phrase or adjective names. That is because a property refers to data, and the name of the property reflects that. PascalCasing is always used for property names.
√ DO name properties using a noun, noun phrase, or adjective.
X DO NOT have properties that match the name of "Get" methods as in the following example:
public string TextWriter { get {...} set {...} }
public string GetTextWriter(int value) { ... }
This pattern typically indicates that the property should really be a method.
√ DO name collection properties with a plural phrase describing the items in the collection instead of using a singular phrase followed by "List" or "Collection."
√ DO name Boolean properties with an affirmative phrase (CanSeek instead of CantSeek). Optionally, you can also prefix Boolean properties with "Is," "Can," or "Has," but only where it adds value.
√ CONSIDER giving a property the same name as its type.
For example, the following property correctly gets and sets an enum value named Color, so the property is named Color:
public enum Color {...}
public class Control {
public Color Color { get {...} set {...} }
}
look at this explanation from CLR via C# (Jeffrey Richter)
public sealed class BitArray {
// This is the indexer's get accessor method.
public Boolean get_Item(Int32 bitPos) { /* ... */ }
// This is the indexer's set accessor method.
public void set_Item(Int32 bitPos, Boolean value) { /* ... */ }
}
The compiler automatically generates names for these methods by prepending get_ and set_ to
the indexer name. Because the C# syntax for an indexer doesn’t allow the developer to specify an
indexer name, the C# compiler team had to choose a default name to use for the accessor methods;
they chose Item. Therefore, the method names emitted by the compiler are get_Item and
set_Item.