It's been removed some time ago. The rationale for the removal was given by Brian Goetz:
Currently the only
implementor is Collection, and all of the other stream-bearing methods
are serving up specialized streams (chars(), codePoints(), lines(), etc)
with a method name that is more suitable than "stream". So I think we
should drop Streamable and leave the stream() / parallel() methods on
Collection (or possibly move them up Iterable).
And also:
I'm starting to think that Streamable is not carrying its weight. I'd
like to consider dropping Streamable, at which point the base-most
implementation of parallel() is in Collection, and I'd also suggest we
consider renaming that to parallelStream().
In this other post he adds:
if everything that is Iterable is effectively
Streamable (because Iterable has a stream()) method, and everything
Streamable is effectively Iterable (because you can turn a Spliterator
into an Iterator), aren't they then the same abstraction?