I want to get a variable naming in a consistent way
I think cgi is an abbreviation,so it should be CGI
Should I change the set_camera_cgi to set_camera_CGI
But what if cgi_set_prefix to CGI_set_prefix
,
Therefore the variable will start with a upcase, will it be more worse?
def set_camera_cgi(self, set_CGI_lst):
try:
cgi_set_prefix=''.join([
"http://",
self.conn_cfg["ip"],
self.cgi["set"]])
cgi_get_prefix=''.join([
"http://",
self.conn_cfg["ip"],
self.cgi["get"]])