I have a Java web application built using Spring MVC. I have a set of JSPs which are the pages, and a set of "model" objects which are sent to the JSPs to populate/receive the form data. Here is a simplified view from the JSP down to the database layer:
showCustomer.jsp // JSP page using the "CustomerViewDao"
org.mycompany.views.CustomerViewDao // view backing (model) object
org.mycompany.controller.CustomerController // controller layer
org.mycompany.service.CustomerService // service layer
org.mycompany.model.Customer // Hibernate entity
Is there an accepted naming convention for these model objects? I chose "xxxDao" for "Data Access Object" and was told this was not a "good" choice. Is there a better choice and what would it be?