In Python code, what is the canonical way of dealing with well-known acronyms when naming classes, methods and variables?
Consider, for example, a class dealing with RSS feeds. Would that rather be this:
class RSSClassOne:
def RSSMethod(self):
self.RSS_variable = True
class ClassRSSTwo:
def MethodRSS(self):
self.variable_RSS = True
or this:
class RssClassOne:
def rssMethod(self):
self.rss_variable = True
class ClassRssTwo:
def MethodRss(self):
self.variable_rss = True
I.e. what is more important, keeping the acronym capitalization or the recommendations of PEP 008?
Edit: from the answers, I conclude that this would be the way to go:
class RSSClassOne:
def rss_method(self):
self.rss_variable = True
class ClassRSSTwo:
def method_rss(self):
self.variable_rss = True