I have a class which is responsible for sending and receiving messages. Messages are sent by using myInstance.send(message, channel)
and messages are received by registering a MessageListener
with a channel to listen on.
I would usually just call this something fairly generic such as MessageManager but I have recently read Naming Classes - How to avoid calling everything a "<WhatEver>Manager"? which made me try and find another name. The closest I could come to a good name was MessageDispatcher which doesn't really convey the fact that also receives messages. Are there any generally used names for a class of this nature?