So I'm working on my first true MVC website development (before now I've been using a template which was already developed). There we had a controller for controls (forms etc.) and then another controller just to deal with all HttpPost actions etc. Because of this is meant I could have a partial view called _ContactForm in both controller, one would set up the form view, the other would deal with the post back from the form.
I'm just wondering if there are any standard naming conventions now that I am using one controller. I have a partial view called _ContactForm which setups the view but Visual Studio informs me that I can't have a second _ContactForm to deal with the HttpPost even though I prefix the method with [HttpPost].
Is it best to have one method prefixed with an underscore and the other not, or is there some naming convention that is generally used?
Any help would be much appreciated!
Thanks, Mike.