I'm writing a little library for myself which has a class that contains hexfields with their cube coordinates x,y and z. Now I usually mark my member variables with a leading m, e.g. int mPosition; or mX, mY, mZ, in this specific case. This would lead to the getter being named getmX().
This is pretty straightforward, but is somehow not as readable as getX(). Would you say it is acceptable to use mX in the class, but rename the publically visible getter to getX()? Or is there a reason to stay consistent? There will not be a publically available setter.