1

I'm trying to figure out the way to see number of CPU cores available, its frequency, cpu flags etc. as well as RAM amount, i.e. what I can get in Linux via /proc/cpuinfo and /proc/meminfo.

Both OpenSolaris and OpenIndiana only maintain process IDs in /proc.

Mark
  • 6,052
  • 8
  • 61
  • 129
  • Stack Overflow is a site for programming and development questions. This question appears to be off-topic because it is not about programming or development. See [What topics can I ask about here](http://stackoverflow.com/help/on-topic) in the Help Center. Perhaps [Super User](http://superuser.com/) or [Unix & Linux Stack Exchange](http://unix.stackexchange.com/) would be a better place to ask. Also see [Where do I post questions about Dev Ops?](http://meta.stackexchange.com/q/134306). – jww Jun 08 '16 at 20:00
  • You should use `isainfo -v` for `/proc/cpuinfo` on Solaris. It gives you the cpu feature flags like ***`ssse3 ahf cx16 sse3 sse2 sse fxsr mmx cmov amd_sysc cx8 tsc fpu`***. – jww Jun 08 '16 at 20:02

1 Answers1

3

The methods in this document will be pretty close.

CPU data can be found using psrinfo -v. Installed memory via prtconf | grep Memory.

Andrew Henle
  • 32,625
  • 3
  • 24
  • 56
  • 1
    Also `/usr/sbin/prtdiag` on many systems will show CPU model info & RAM module sizes. – alanc Jun 18 '15 at 19:58
  • Thanks Andrew and alanc. I have another question -- how to determine if a running system is in 32-bit or 64-bit mode? I think I could check /boot/grub/menu.lst, but on my system it only defines timeout and doesn't show which kernel from /platform/... it actually boots. Something similar to /proc/cmdline in linux? – Mark Jun 18 '15 at 20:33
  • 1
    `isainfo -k` will show you what kernel is running. `amd64` is a 64-bit x86 kernel, `i386` (IIRC) is a 32-bit x86 kernel. `isainfo -v` will show you the entire instruction set(s) including extensions such as SSE3 that can run. – Andrew Henle Jun 18 '15 at 20:50