The whole generics thing is kinda throwing me for a loop, and more so the RTT.
Specificis? Ah well here's the gist:
enum QueryHelper {
query1,
query2;
static <T> QueryHelper getQueryHelper (Class<T> expectedReturn) {
if (expectedReturn.isInstance (SomeRelatedClass.class))
return query1;
else
return query2;
}
}
and then I would call it like so:
...
QueryHelper helper = QueryHelper.getQueryHelper(SomeRelatedClass.class);
...
This is so that I can really flexibly assign the query return type in the actual helper. It does some casting and object creation. What I am seeing is that there is no match, should I be doing this some other way? Or is the whole idea just bad?
And the real heart of this is that I don't understand the difference between class.isInstance and the instanceOf operator? Should I be using the latter?