I've recently started with Django web application development and now I want to put wood behind the arrow.
To do the job properly I started over and started to think of a correct naming convention for my web application. I've read through this blog article.
Until now, I've just created a project called myproject
and the app is called myproject_app
.
I realized, the only thing my myproject_app
does is have the models.py
with the database scheme, so I wondered if that is the way to go, or if I took a wrong turn somewhere.
With the app
having nothing more that the description of my database, it's hard to think of a proper name and not just suffix it with _db
or something like that.
To my question: What code belongs to a Django app and what is the appropriate naming convention for such apps?
edit: I did come by this Stackoverflow question, but it does not cover the code one is supposed to have in the Django app, just like it doesn't cover that in the blog article.