Is it possible to make eclipse generate GetVar1() instead of getVar1() ? (with capital G)
Asked
Active
Viewed 1,872 times
2 Answers
18
I very much doubt it, since that breaks both normal Java naming conventions for methods and the JavaBeans properties rules.
I would strongly, strongly recommend that you abide by Java naming conventions. Why would you want to make your code look inconsistent with all the other Java libraries including the standard library?

Jon Skeet
- 1,421,763
- 867
- 9,128
- 9,194
-
2Not to mention the way this would make his code incompatible with all sorts of things which use reflection and depend on the JavaBeans rules. – Paul Tomblin Jan 02 '11 at 18:53
-
I will stick with java naming conventions! thanks it's very appreciated! – ZeroCool Jan 03 '11 at 17:59
-
The first example of needing properly named getters and setters that comes to mind is serialization. – Brian Jan 03 '11 at 20:16
-
@Brian XMLEncoder/XMLDecoder require well-formed setters and getters, but ObjectOutputStream/ObjectInputStream do not. – Mike Clark Jan 05 '11 at 20:12
1
This is not possible because Eclipse follows Java naming conventions for generating getters and setters.

Andrew Eisenberg
- 28,387
- 9
- 92
- 148