When I was using Asp.Net Core 2.0 Web Api for Json(Cammel Case), I came across the following:
UNCouncil --> unCouncil
Most stack overflow sources like this question got me into thinking what is the correct implementation? That question only cares for the first letter.
UNCouncil --> uNCouncil
Clearly, the Microsoft Implementation seems More Readable, but when it comes to this:
UNCouncilWFPSection --> unCouncilWFPSection
Shouldn't WFP be Wfp? What's the recommended way?
In this snippet in Netwonsoft.Json Git Repository, only first letter is given consideration.
According to this article in wiki.c2.org,
- The word does not end on a capitalized letter: CamelCasE
- No two capitalised letters shall follow directly each other: CamelCAse
Clearly, both of these are not properly satisfied by any of these contract revolvers.
So, My question sums to the following:
- Shouldn't (the proper implementation)
ToCammelCase
of two words be equivalent, just like Lower/Upper case? [Try: AppleINC vs AppleInc] - Is there a proper specification or is it whatever the developer feels?