I have this line of code:
map (\(u,v) -> flatTorus n u v) gridUV
Hlint
suggests me to replace it with
map (uncurry (flatTorus n)) gridUV
What is the motivation of this suggestion ? Is it for shortness only, or something else (performance) ? Because though it is longer, I find the first code more easy to read.
In fact my question is more general,, because this is just an example among others: does Hlint
suggestions are generally based on a shortness motivation only or are there other improvements behind the suggestions ?