I have the following code line:
run_command('/usr/bin/msgabc -A30 --before "/etc/conf/help.txt" &')
And I would like to write it the "correct way" by using constants and make it more generic.
I have tried to transform it into the following piece of code:
import os
MSGABC_PATH = "/usr/bin"
MSGABC_BINARY = "msgabc"
MSGABC_COMMANDLINE_ARGS = "-A30 --before \"/etc/conf/help.txt\""
run_command("%s %s &" % (os.path.join(MSGABC_PATH, MSGABC_BINARY), MSGABC_COMMANDLINE_ARGS)
But the latter makes it less readable for the new reader.
Which method would be the most generic without losing readability?