I am a Japanese web developer.
I am not good at English , but I want to be better.
I am making a task application, and I made a function like this in order to check if there are empty entry.
private get doEmptyItemsExist(): boolean {
return this.title === '' || this.detail === '' || this.deadLine === ''
}
I use this for validate.
'doEmptyItemsExist'
Is this proper English?
And is this proper name for this function?
Is it better to say just 'emptyItemsExist'?
I thought if it starts with 'do', it can tells you that it returns boolean simply.
And I want to know 'emptyItemsExist' or 'emptyItemExists' which is better.
And I want to know proper word for 'item', like I thought maybe it's better to say 'entry'.
Someone, please help me.