Is that a good way to define a class like this:
class states:
INACTIVE = 'Inactive'
ACTIVE = 'Active'
PENDING = 'Pending'
BANNED = 'Banned'
to keep a list of possible values and then get them as, e.g. states.INACTIVE
, so when I want to change user's status, I do something like this: user.status=states.BANNED
and it gets value 'Banned'
. I use it to quickly access these values with IntelliSense in my IDE with ctrl-space and it also makes it safer against typos. Though, I am not sure it's a good approach to create a class for just keeping some strings. How can I organize it a better way or is that a good solution?