Stylecop seems inconsistent in naming parameters or perhaps I'm missing something?
I have
Movement movement;
public void SetMovement(Movement movement)
{
this.movement = movement;
}
which complains about my parameter hiding a field, which is understandable. Then I try to name the parameter differently
public void SetMovement(Movement _movement)
{
this.movement = _movement;
}
which will complain about underscores and Hungarian notations, etc.
It seems the only way to satisfy stylecop in this case would be to name the parameter something different like
public void SetMovement(Movement movementParameter)
{
this.movement = movementParameter;
}
Which of these would be considered the best 'style'?