94

I just want to work with VirtualBox but now I am getting this type of error.

I could not find a proper solution.

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

enter image description here

Not A Bot
  • 2,474
  • 2
  • 16
  • 33
Shibaji Debnath
  • 1,105
  • 1
  • 10
  • 16
  • 3
    The error message is quite vague. It says On Linux, open returned ENOENT. What about on macOS? It turns out that I have to explicitly allow VirtualBox in the macOS system preference. Go to System Preferences / Security & Privacy. Click “Allow” in the window below. Reboot System. Now VirtualBox no longer complains about kernel driver. – Muhammad Zain ul Abdeen Mar 28 '21 at 07:54

13 Answers13

122

MAC with BIG SUR -- Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where the error is:

suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Download and install the latest VirtualBox 6.1.18 or higher. And then follow the below steps to resolve.

Step 1 - run:

sudo kextload -b org.virtualbox.kext.VBoxDrv

Step 2: Go into System Preferences->Security & Privacy

Step 3: Unlock the security center

Step 4: Approve the software by Oracle

Step 5:

sudo kextload -b org.virtualbox.kext.VBoxNetFlt
sudo kextload -b org.virtualbox.kext.VBoxNetAdp
sudo kextload -b org.virtualbox.kext.VBoxUSB

Step 6: Reboot

JimLohse
  • 1,209
  • 4
  • 19
  • 44
GopiKarthi Android
  • 1,348
  • 1
  • 8
  • 7
  • 1
    When I run the above I get the following for each of the commands: `Executing: /usr/bin/kmutil load -b org.virtualbox.kext.VBoxDrv Error Domain=KMErrorDomain Code=28 "Loading extension(s): org.virtualbox.kext.VBoxDrv requires a reboot" UserInfo={NSLocalizedDescription=Loading extension(s): org.virtualbox.kext.VBoxDrv requires a reboot}`. I get the same after I reboot. Any ideas? – rafagarci Nov 11 '21 at 09:18
  • Uninstalling and reinstalling with reboots in between and allow in System Preferences didn't work for me. Loading the kernel extensions in Terminal did. Thank you so much. – orkoden Dec 12 '21 at 18:33
  • Also works for macOS Monterey 12.2.1. Thanks – K_inverse Apr 24 '22 at 01:43
  • 1
    Precisely - steps 2, 3, 5 followed by system reboot. – parasrish Aug 15 '22 at 12:12
21

Registering the .kext directly via terminal solved this issue for me.

sudo kmutil load -p '/Library/Application Support/VirtualBox/VBoxDrv.kext'

There should be a prompt in System Preferences to allow the kernel, which will require a reboot.

Reboot and run command cd ˜/Homestead && vagrant up

Sohail Ahmed
  • 1,308
  • 15
  • 17
  • 1
    This works for me, but I never see the "prompt in System Preferences to allow the kernel, which will require a reboot" and I have to do it manually every time. After all, it works. – Neal.Marlin Nov 22 '21 at 09:21
  • 1
    I've spent a couple of hours trying to solve this until I found your post. It helped! Thanks! – Konstantin May 02 '22 at 14:51
  • I'm using mac pro intel 2020, it's broke my display(mess of black & white dot) on before restart and I can't undo it yet. – Sofyan May 08 '22 at 12:09
  • @Sofyan Its sad to hear this. But this problem has been fixed on my Laptop as well as other people too. may be there is something else went wrong. – Sohail Ahmed May 09 '22 at 18:09
  • @SohailAhmed I think it's only on my laptop, and I have my own solution for the main issue by reinstalling the virtual box, and for the "graphic issue" I don't know why but it's fixed too. – Sofyan May 10 '22 at 13:12
15

On MacOS Monterey 12.4, I just installed the latest version and opened VirtualBox (version 6.1.34 r150636 (Qt5.6.3)). Then:

Step 1: Went into System Preferences->Security & Privacy.

Step 2: Unlocked the security center.

Step 3: Approved the software by Oracle.

I haven't uninstalled my old virtualBox or restarted the machine or typed any code.

Clayton Maciel
  • 161
  • 1
  • 4
  • Perfect. This was what I just used on VirtualBox 6.1.36 and Monterey 12.5 intel Mac and worked great. I think I missed the prompt when I installed VB – Preet Sangha Aug 01 '22 at 05:15
  • step 3 doesn't seem to be available on my version of Monterey – con Sep 22 '22 at 15:08
11

Big Sur disables the VirtualBox kernel extensions as part of the installation process. You can verify this by running:

kextstat | grep -v com.apple

If the kernel extensions are installed, you will see something like this:

Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
  184    3 0xffffff7fa232d000 0xb2000    0xb2000    org.virtualbox.kext.VBoxDrv (6.1.18) 9C1C33DF-8061-30A2-9266-C9284816A6A2 <8 6 5 3 1>
  187    0 0xffffff7fa240a000 0x5000     0x5000     org.virtualbox.kext.VBoxUSB (6.1.18) 51E577B4-43B6-359F-B817-9C63A69E7943 <186 184 62 8 6 5 3 1>
  188    0 0xffffff7fa2405000 0x4000     0x4000     org.virtualbox.kext.VBoxNetFlt (6.1.18) 96E530DE-E34D-3447-89A5-FCF6646AE47E <184 8 6 5 3 1>
  189    0 0xffffff7fa23ff000 0x2000     0x2000     org.virtualbox.kext.VBoxNetAdp (6.1.18) 63EFABA5-3341-3BEB-B47A-AAFCDD7312A5 <184 6 5 1>

If you don't see the extensions loaded, the easier fix is to delete your current VirtualBox app, download and install the lastest version and then go the Security & Privacy System Preferences Pane. You should see a message that some applications require a restart to work correctly.

Restart your Mac and VirtualBox should now work. You can re-run the kexstat command just to be sure the extensions were loaded.

Gene Z. Ragan
  • 2,643
  • 2
  • 31
  • 41
8

Here is how I solved the issue on MAC with MONTEREY

Update 09 december 2021 : installing the latest version (VirtualBox-6.1.30-148432-OSX.dmg when updating this post) completely solve the issue on my machine

Initial post :

  1. Download the latest installer of VirtualBox (VirtualBox-6.1.28-147628-OSX.dmg when writing this post)
  2. Launch the installer
  3. Double click on the file VirtualBox_Uninstall.tool in order to uninstall VirtualBox
  4. Reboot
  5. Reinstall VirtualBox
Moussa
  • 4,066
  • 7
  • 32
  • 49
7

Solution worked for Big Sur (no need to delete anything):

  1. Update VirtualBox
  2. Install VirtualBox Extension Pack https://www.virtualbox.org/wiki/Downloads
  3. Settings -> Security -> General settings -> Unlock settings
  4. On "General settings" form turn allow application usage checkbox from "App Store and others..." to "App Store" and back to "App Store and others..." (to make sure Mac recognised the changes made before on steps 1-2)
  5. Go to "Additional settings" ("General settings" form button right after application usage checkbox), system will show Applications changes made before (steps 1-2), push "Ok" and system will ask for reboot
  6. After reboot VirtualBox will work
6

I also got the same error while trying to run Windows 10 on macOS Big Sur 11.6, but I was easily able to fix the issue by navigating to System Preferences > Security & Privacy. There, under allow apps downloaded from section I found something like Oracle wants to install additional updates, and I gave permission. My Win 10 VM started to work. I hope this help.

aakardhakal
  • 61
  • 1
  • 2
1

after googling for few days and no solution worked for me on macos

I run the below commands

sudo kextload -b org.virtualbox.kext.VBoxDrv
sudo kextload -b org.virtualbox.kext.VBoxNetFlt
sudo kextload -b org.virtualbox.kext.VBoxNetAdp
sudo kextload -b org.virtualbox.kext.VBoxUSB

then go to "https://www.virtualbox.org/wiki/Downloads" and download "VirtualBox 6.1.30 Oracle VM VirtualBox Extension Pack" all platform

then open your virutalbox preferences --> choose extension --> and add the extension you just downloaded and eveything will be ok

1

Another restart of the system solved my problem as I was already at the most current version of virtualbox. My macOS upgrade was from Big Sur 11.6.1 to 11.6.4.

ouflak
  • 2,458
  • 10
  • 44
  • 49
FrankS
  • 11
  • 1
1

None of the methods here worked for me, the option to approve the driver in System Preferences / Security & Privacy never appeared.

The only way I could get to approve the extension was rebooting in recovery mode, and then giving consent to the Oracle Developr ID running in the Terminal the following command:

spctl kext-consent add VB5E2TV963

Then after a reboot, I could approve the driver and VirtualBox works just fine. Tested in Monterey 12.3.1

Full credits to this site: https://appuals.com/kernal-driver-not-installed-rc-1908-error-mac/

  • +1 for this. Exactly same thing for me. Restart -> press and HOLD CMD+R --> Recovery Mode. --> Utilities --> Terminal --> the `spctl` cmd – mitnk Jun 10 '22 at 07:48
0

I started getting this issue when my Mac updated from Big Sur to Monterey. I just downloaded and installed the latest version of VirtualBox on my Mac and it started working like earlier.

Ganesh
  • 181
  • 1
  • 5
0

I couldn't make the option to allow the kext appear in System Preferences either. Rebooting, reinstalling VBox and running sudo kextload -b org.virtualbox.kext.VBoxDrv didn't help.

I discovered another cause: in my case, I had to enable WiFi for internet access and also allow syspolicyd to contact api.apple-cloudkit.com in Little Snitch (it is allowed by default, but I'd disabled that rule). Then running sudo kextload -b org.virtualbox.kext.VBoxDrv forced syspolicyd to verify the signature (or whatever my data it may be uploading) — the option appeared in Security & Privacy and I could allow it finally.

So if anyone has such an issue, try verifying that syspolicyd can contact api.apple-cloudkit.com.

(I also posted this discovery on my blog: https://egeek.me/2022/06/25/kexts-for-virtualbox-do-not-load/).

eugene
  • 216
  • 2
  • 6
-3

I had face this issue before and I tried all the threads in this question and doesn't work, then I tried to add the iso file from the setting tab like shown in screenshots, and it worked well.

VirtualBox kernel error

VirtualBox kernel error

medxone
  • 3
  • 5
  • 2
    As it’s currently written, your answer is unclear. Please [edit] to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers [in the help center](/help/how-to-answer). – Community Oct 03 '21 at 00:23