Is there a safe way to move the following code? I am working on an open source archived game which was minified and am unfamilar with the syntax
if (
(72 !== event.which && UI.hideHelp(),
null != c && P(event.which))
){
// some stuff
}
What is actually happening here? If I was to make it more readable, does it become this:
if (72 !== event.which){
UI.hideHelp();
}
if ((null != c && P(event.which))){
// some stuff
}
Or this?
if ((null != c && P(event.which))){
if (72 !== event.which){
UI.hideHelp();
}
// some stuff
}