I'm trying to find a name similar to what i,j
are for loops, or x,y
is for coordinates etc.
I have a code like this:
DbSetup.setupCommon(x -> HibernateHelper.addResource(SpecificEntityHelper.HIBERNATE_RESOURCE, schemaName));
In this case x
is not a required variable name and I found it is used in few places in code base of our project, so probably is
Of course in this specific case I can not use a static reference to the function HibernateHelper::addResource
and it sounds like there is no other way to not to have a name of the variable at all.