Is there any way I can be less verbose in JavaScript by pointing a local variable by to an objects property?
For instance in PHP I can do this:
$obj->subobject->property = 'Foo';
$property =& $obj->subobject->property;
$property = 'Bar';
echo $obj->subobject->property;
// output 'Bar'
It's not a very good example but you get the idea.
I want to copy this behaviour in Javascript. I'm quite often having to go quite deep into objects and it's getting quite annoying having to do:
if (please.stop.making.me[somevar].type.so.much.length) {
please.stop.making.me[somevar].type.so.much[newSubObjectKey] = anObject;
}
// perform more operations on the object down here
It would be a lot easier to read and a lot easier to type:
var subObj = is.much.easier.to.type.once;
if (subObj.length) {
subObj[newSubObjectKey] = anObject;
}
// now that's much better
I know I should really know this already, but I'm just advancing to "advanced novice" in JavaScript.
A(a);
function A (a) { arguments [0] = 44; console.log (a); // outputs 44, not 55 }` – tgoneil Jun 30 '14 at 19:02
' – tgoneil Jun 30 '14 at 19:20