I read this article and I have a question about it.
The Repository pattern is a Facade, that abstracts your persistence away from your Domain. On one side it pretends to be a collection – on the other it deals with the technical concerns of your persistence implementation.
Does that mean that you name the methods in repository as you would if you made a collection. For example:
addDomainModel(...)
getDomainModel(...)
and so on? Or would you name the methods:
saveDomainModel(...)
fetchDomainModel(...)
What would be best, or most correct? And should I have the method names saying what it adds, or just:
add(...)
get(...)
as it would in a normal collection?
http://devlicio.us/blogs/casey/archive/2009/02/20/ddd-the-repository-pattern.aspx