Possible Duplicate:
Style: Dot notation vs. message notation in Objective-C 2.0
In apple documentation for NSArray it says: "Instance method>" "count". So, normally I would write [[NSArray array] count]
. However, [NSArray array].count
works just fine... And recently I figured out that UIScreen.mainScreen.bounds
is also accepted. mainScreen
is a class method for UIScreen
.
Anyone thought about which style to use (and why)? Please comment.